Symptom
PTR records exist for reverse IP addresses, but "A" records do not exist for forward IP addresses
Steps to Test
- Verify this pattern exists inside 1.1.10.in-addr.arpa reverse zone
1.1.1.10.in-addr.arpa PTR mail1.domain.com
2.1.1.10.in-addr.arpa PTR mail2.domain.com
3.1.1.10.in-addr.arpa PTR mail3.domain.com
- Confirm "A" records for mail1.domain.com, mail2.domain.com, mail3.domain.com do not already exist in domain.com zone.
Root Cause
"A" Records for forward hostname listing in the Points To of PTR records do not exist.
Steps to Resolution
- Login to UltraDNS
- Click on Domains
- Click on <domain.com>
-
Click Add+ under A Records
- Enter mail1.domain.com. under Host
- Enter 10.1.1.1 under Points To
- Enter desired value (for example 3600) under TTL
- Click SAVE and add another
-
Click Add+ under A Records
- Enter mail2.domain.com. under Host
- Enter 10.1.1.2 under Points To
- Enter desired value (for example 3600) under TTL
- Click SAVE and add another
-
Click Add+ under A Records
- Enter mail3.domain.com. under Host
- Enter 10.1.1.3 under Points To
- Enter desired value (for example 3600) under TTL
- Click SAVE
Additional Information
Insight Into Step 3: The reverse address ends in 'in-addr.arpa' and the hostname for server ends in 'domain.com'. Therefore the PTR should exist in the in-addr.arpa zone and the "A" record should exist in <domain.com>. This is the most common scenario, one where the "A" record and PTR are not in the same DNS zone.
Insight Into Steps 4-6: In these steps, you are taking the Points To value of the PTR (reverse) records and using that as the Host of the forward record ("A" Record) while using the forward IP of the Host as the Points To of the "A" record.