Symptom
Office365 indicates SRV records are incorrect even though I followed Microsoft's instructions on adding the records
Root Cause
Service name field did not have '.' between service and protocol
Steps to Resolution
- Login to UltraDNS
- Click Domains
- Click on the <domain> that has the SRV record in it
- Scroll down to and click the SRV (Service Locator) section
- Update '_service_protocol.domain.com. TTL IN SRV priority weight port targetdomain.com.' to '_service
._protocol.domain.com. TTL IN SRV priority weight port targetdomain.com.'