Symptom
DNS not resolving and receives SOA instead of "A" record in DNS tests
Steps to Test
- Browse to http://www.digwebinterface.com/
- Enter <testdomainforkb.com> under Hostnames or IP addresses:
- Click radio button next to Resolver and leave at Default
- Received SOA for .com like seen below:
testdomainforkb.com@8.8.4.4 (Default):
com. 899 IN SOA a.gtld-servers.net. nstld.verisign-grs.com. 1433972065 1800 900 604800 86400
5. Enter <testdomainforkb.com> under Hostnames or IP addresses:
6. Click radio button next to Authoritative and enter pdns1.ultradns.net in the text box below
7. Received expected answer (not a SOA for for com.)
Root Cause
Registration problems were causing the SLD <testdomainforkb.com> to not resolve
Steps to Resolution
Reach out to your Registrar to fix any registration problems with your domain
Additional Information
Insight into Cause Test Step 4: Often times the authority section is overlooked in this instance. Notice it is for the .COM TLD instead of the domain being queried. This points to a problem with the registration as the TLD servers do not know where to forward the DNS query to. The domain could be expired, locked or just misspelled in the lookup. A WhoIs will confirm any kind of registration changes. Another way of looking at this is with a dig +trace (dig testdomainforkb.com +trace). This command allows the user to follow the query from start to (hopefully) the authoritative name servers. If the last server to answer is from the TLD, there is a problem at the registry.